
5 Min Scheduled Maintenance Period For EU Region Upgrade
Completed 16 Oct at 06:00pm UTC.
Updated
We have successfully completed this upgrade. This upgrade significantly improves our documents / attachments uploaded file storage capabilities, performance, and reliability. Thank you for your patience.
If you notice any issues with documents or file uploads over the next period, please report them to help@d4h.com for troubleshooting.
Completed
Maintenance completed

Started
We expect to put Team Manager into Maintenance Mode for approximately 5 minutes, during a 60-minute window, starting on Monday 16th at 1700 UTC+0. We're planning a significant upgrade to the storage systems we use which will provide better storage capacities, disaster recovery, and security.
Please note, you may encounter temporary disruptions when uploading and downloading documents and attachments for a very short period after this release.